AutoSSL errors after migration

Operating System & Version
Linux, apache 2.4.52, x86_64
cPanel & WHM Version
94.0 (build 19)


Mar 2, 2020
cPanel Access Level
Root Administrator
Hi there,

So earlier today Godaddy migrated my webhosting, one that is running on Cpanel with autossl. They updated the IP to the new server in the DNS (which is not in Cpanel itself, but in their own DNS system). My website then became unsecure because autossl had failed.

As soon as I noticed, I kept running autossl within CPanel until I got it to work for, and I didn't touch anything other than clicking the run autossl button multiple times for about 30 minutes. It failed often, even after it succeeded once and had "auto ssl domain validated" for these URLS. Those errors went away for these 3.

But now keeps returning this error:

DNS DCV: No local authority: “”; HTTP DCV: The system failed to fetch the DCV (Domain Control Validation) file at “” because of an error: The system failed to send an HTTP (Hypertext Transfer Protocol) “GET” request to “” because of an error: (XID gp6e29) The response exceeded the maximum length (16 KB). (<!DOCTYPE html><html lang="en" dir="ltr"><head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> …) at /usr/local/cpanel/Cpanel/SSL/ line 657..

Cpanel was a CNAME in my DNS zone, just like www is. I tried switching it to an A-record just in case. Same problem (7 hours have passed since that change). I read elsewhere on this forum that it might be because of htaccess redirecting http to https, which it does and always has been doing. Changed that for the well-known folder. Still no solution. And of course www and the others are also redirecting http to https. Plus, this was never an issue before the migration.

I don't visit the cpanel subdomain so I don't really need it, but I do want to understand what's going on because this error might suddenly start to pop up for my next www or root SSL renewal and so on.

What's going on here please? I don't have access to WHM in this case.

Thank you!
Last edited by a moderator:


Jurassic Moderator
Staff member
Oct 19, 2014
cPanel Access Level
Root Administrator
Hey there! You already mentioned the most obvious issue, and that's the https redirect, as that usually is what causes that particular message. Does the server use Nginx or Varnish or other tools, or is that something you don't know since you don't have root access to the machine?

Without root access, you may need to reach out to the hosting provider to have them check the system as you likely will not be able to resolve this on your end.