cPanel support doesn't help resotre back wrong update


Jan 11, 2010
I am old customer using cpanel licenses in all my vps servers.

i have 1 vps dediated server for my 2 web hosting websites, i installed cpanel for easy using of control panel,

today, i noticed that there is available updates in my cpanel, so i tried install using WHM and i see openssl conflicts, so login my ssh, and i use yum to update, but i still see the openssl conflicts, so i remove the i386 version of openssl, i thought that my system is not using i386 becuase my OS is x86_64. After uninstall, i cannot run my cpanel and other services. i tried using console to login my vps but i am still cannot rollback my version of openssl.

i contacted the cpanel support and asking help to resotre my last wrong steps, but he denied my request. even i ask a little favor to restore in terms that i am using the cpanel but he refused it.


Staff member
Apr 11, 2011
Hello :)

There have been some recent issues with the CentOS YUM repositories regarding the openssl package. A discussion on the CentOS forums concerning this issue can be found at:

If this is the same issue you are experiencing, most users have reported success using the method mentioned on the following thread:

Please note that if your VPS is not accessible via SSH, we will not be able to troubleshoot the issue. Could you post the ticket number here so can take a look?

Thank you.