EasyApache 4 August 23 Maintenance and Security Release

Status
Not open for further replies.

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
17,469
2,842
363
cPanel Access Level
Root Administrator
cPanel, L.L.C. has released a security update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.
  • ea-php82 v8.2.9-1
  • ea-php82-meta
    • EA-11619: Update ea-php82 from v8.2.8 to v8.2.9
      – Libxml:
      Fixed bug GHSA-3qrf-m4j2-pcrr (Security issue with external entity loading in XML without enabling it). (CVE-2023-3823)
      – Phar:
      Fixed bug GHSA-jqcx-ccgc-xwhv (Buffer mismanagement in phar_dir_read()). (CVE-2023-3824)
  • ea-nodejs18 v18.17.1-1
    • ZC-11124: Initial build
  • ea-nodejs20 v20.5.1-1
    • ZC-11127: Initial build
  • ea-cpanel-tools v1.0-78
    • ZC-11033: Add support for packages w/out an `ea-` prefix in EA4 profiles
    • ZC-11135: Add ea-nodejs18 and ea-nodejs20 to additional packages list
    • ZC-11149: Add touchfile for nginx cpwrap that will ignore memory limits and set it to unlimited to readme
  • ea-nginx v1.25.1-4
    • ZC-11149: support touchfile for nginx cpwrap that will ignore memory limits and set it to unlimited
    • ZC-10396: Remove ea-passenger-src dependency and other passenger code
  • ea-nginx-passenger
    • ZC-10396: Create ea-nginx-passenger
  • ea-nginx-standalone
    • ZC-10396: Add ea-nginx-passenger dependency
SUMMARY

cPanel, L.L.C. has updated packages for EasyApache 4 with PHP version 8.2.9. This release addresses vulnerabilities related to CVE-2023-3823 and CCVE-2023-3824. We strongly encourage all PHP users to upgrade to version 8.2.9.

AFFECTED VERSIONS
All versions of PHP through 8.2.8.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2023-3823 – HIGH
PHP 8.2.9
Fixed vulnerability related to CVE-2023-3823.

CVE-2023-3824 – CRITICAL
PHP 8.2.9
Fixed vulnerability related to CVE-2023-3824.

SOLUTION
cPanel, L.L.C. has released updated packages for EasyApache 4 on August 23, 2023, with PHP version 8.2.9. Unless you have enabled automatic package updates in your cron, update your system with either your package manager or WHM’s Run System Update interface.

REFERENCES
https://www.cve.org/CVERecord?id=CVE-2023-3823
https://www.cve.org/CVERecord?id=CVE-2023-3824
https://www.php.net/ChangeLog-8.php#8.2.9

https://news.cpanel.com/wp-content/uploads/2023/08/EA4-2023-8-23-CVE.signed.txt

Information about all releases this year can be found in the 2023 EasyApache 4 Changelog and the EasyApache 4 Release Notes. You can also sign up for our EasyApache Development and EasyApache Production mailing lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
 
Status
Not open for further replies.