imunify notifications (free version of imunify)

audrey

Well-Known Member
Oct 18, 2006
129
6
168
Hi

I am trying to change the contact notifications on all of my servers for imunify (the free version).

The notification emails that I am receiving about imunify claim that the notifications are set to "high" in the contact manager of WHM.
The notification emails say to change the notification settings go to
........./scripts2/editcontact?event=Application

All of my servers have this setting set to low and I am still getting notifications to the "high" notification settings in the WHM and the notification emails still say that the notifications are set to high in the contact manager of WHM even though they are set to "low".

I have disabled Imunify on one of my servers, but, I would rather keep imunify enabled - I just do not want to receive notifications about imunify other than to the "low" notification settings in WHM contact manager.

Thanks for any advice
Susan
 

retechpro

Well-Known Member
Dec 23, 2022
141
16
18
Pakistan
cPanel Access Level
Root Administrator
You can change the email by opening the imunify setting and scroll down the last and change the email there.

you can use this command to disable notifications for imunify.

whmapi1 set_application_contact_event_importance app=Imunify event=Generic importance=Disabled

or

imunify-antivirus config update '{"ADMIN_CONTACTS": {"enable_icontact_notifications": false}}'

I hope issue will be resolved.
 

audrey

Well-Known Member
Oct 18, 2006
129
6
168
Thanks - but - this does not solve the problem.

I do want to receive notifications - I just do not want them to go to the "high" importance email settings in the WHM contact manager.

As far as - you saying
"You can change the email by opening the imunify setting and scroll down the last and change the email there"'
That is not an available option anywhere in the free version of imunify settings-
I searched the settings at least 10 times on all of my servers before I posted this in the forum and I looked again after your post and there is not a place to change the emails in imunify setting
and
imunify emails claim to be using the settings in the contact manager of the WHM not a setting in imunify

my servers are using Centos 7 and cpanel version 108.0.11
 
Last edited:

retechpro

Well-Known Member
Dec 23, 2022
141
16
18
Pakistan
cPanel Access Level
Root Administrator
alright. Use this command to set on low, if not working in contact manager and then check. If it help.

whmapi1 set_application_contact_event_importance app=Imunify event=Generic importance=low
 

audrey

Well-Known Member
Oct 18, 2006
129
6
168
Thanks - Hopefully the ssh command will solve-
FYI - I ran the command the way you had it - but got an error - Low must be capitalized. Once capitalized, command appered to be successful. Will see if it solves the notification issue.

[root@server ~]# whmapi1 set_application_contact_event_importance app=Imunify event=Generic importance=low
---
metadata:
command: set_application_contact_event_importance
reason: "API failure: (XID jgskmv) The “importance” parameter “low” is invalid and may only be one of “0, 1, 2, 3, Disabled, High, Low, or Medium”."
result: 0
version: 1
[root@server ~]# whmapi1 set_application_contact_event_importance app=Imunify event=Generic importance=Low
---
metadata:
command: set_application_contact_event_importance
reason: OK
result: 1
version: 1
[root@server ~]#