Insufficient permission in Jailshell and "no input file specified" with email pipe


Well-Known Member
Mar 5, 2002
Vancouver, Canada
I wanted to reply to an old thread but couldn't. The thread was just too old. But the the suggestion in there by mynameanu's solved a major headache for me today...

It started (after migrating to a new server) with an email pipe to a PHP script throwing a "no input file specified" error. The script and its forwarder had been working perfectly for years. I tried all kinds of things, and nothing worked. And then I noticed a "permission denied" error when logging in via SFTP. Logging in via SSH confirmed that I had insufficient permissions in the user's home directory -- I couldn't even the list the directory contents with "ls". Other directories like /var were listing fine.

I then unmounted the virtual home directory as suggestion in the other thread, and the problem was solved!
root@server[~]# umount /home/virtfs/<user>/home/<user>/
The cause of the problem? The first attempt to transfer the account from another cPanel failed. I then restored from a full backup. The failed transfer probably had some left-overs in the /home/virtfs.

Maybe this will help someone else ;)


Staff member
Apr 11, 2011
Hello :)

Thank you for choosing to post the solution you found to our forums. Note that documentation on VirtFS directories is available at:

Jailed Shell (VirtFS)

Thank you.