New Addon domain/sub domain not getting DNS


Well-Known Member
Mar 5, 2020
cPanel Access Level
Root Administrator
I have a few servers, one of which serves as a DNS server. I configured clustering with this DNS server. My other servers were functioning properly, and I recently added a new server which has been running smoothly for almost a month. However, I suddenly encountered a DNS issue with this new server. When my users in cPanel attempted to add an Addon domain or any subdomain, the domain didn't go live. While the DNS server showed that the domain had DNS, a check on a DNS checker website indicated that the site was down and there was no DNS.

Strangely, when I configured the cluster with a new API, it worked. But This is Temporary.

Note: My server provider had briefly shut down this server two days ago for an hour, and the issue started after that. I've tried various fixes, but nothing seems to work permanently. I'm seeking assistance to resolve this situation.


Jurassic Moderator
Staff member
Oct 19, 2014
cPanel Access Level
Root Administrator
Hey there! The main thing we need to know is if the DNS records are being properly sent to the DNS cluster server. You can check that directly in the zone file in the /var/named/ directory on that machine.

If that is happening, there is something happening in DNS that is keeping the record from being loaded properly. If that is NOT happening, there is something keeping the cluster from syncing. It would be best to enable the additional logging option of "Enable verbose logging of DNS zone syncing" from WHM >> Tweak Settings under the "Logging" tab and then you'll get more details about the sync process in /usr/local/cpanel/logs/dnsadmin_log