Scientific Linux - Making cPanel install...


Dec 16, 2011
cPanel Access Level
Root Administrator
I standardized on Scientific for my recent server deployments (CentOS community stability worries me). Problem is, cPanel didn't want to install on it. Not a huge deal, i could have built it with CentOS, but CentOS 6.0's kickstart is completely broken. So i used SL 6.1 instead. Now CentOS released 6.1 a week ago, but my server shipped before that release and is now online in a data center 1500 miles away from me.

So i'm starting this thread to put down what i did to make cPanel work in SL 6.1. I'm not sure what future problems will crop up, hopefully none. Hopefully cPanel will support SL soon.

Installing cPanel:
"sh latest" fails quickly stating that "sl-release-6.1-2.x86_64" is unsupported. Indeed "rpm -qf /etc/redhat-release" reports this version. The fix? Install the centos-release-6.1 package, then remove the sl-release package.

Now "rpm -qf /etc/redhat-release" reports that my system is CentOS 6.1 :)

During the install, easyapache fails with a YUM error, but cpanel installation continues. I tried the yum command once the install was complete, and it still errors out. I reinstalled sl-release and removed centos-release and tried the yum command again. Works!

Now easyapache completes and apache is installed.

Last problem is bind/named is not installed. The fix was found here:

That solution worked and now named is running.

Next i restarted cpanel to make sure all was in order.

Restarting cpanel kicked off a lengthy install that fails. The last messages on the screen before the install failed were concerning libxml. Libxml2 is installed on the server, so that was not the problem. Some googling led me to believe that libxml2-devel might be needed. "yum install libxml2-devel" resulted in a successful restart of cpanel which automatically build rrdtool (and a slew of supporting tools). Subsequent restarts are error free (except chat services that are not configured to run).

If i run into any other problems, i'll post here.
Last edited:


Quality Assurance Analyst
Staff member
Oct 2, 2010
somewhere over the rainbow
cPanel Access Level
Root Administrator