WHM Backup (New not Legacy) completed once, and it won't run again.


Active Member
Mar 9, 2006
Dear All,

I am a new user, and I just moved from a fully managed server to an un-managed one.
I completed the migration of my 50 odd domains last week and everything is running fine :)

My Server is running WHM 11.42.1 (build 16).
I am having a problem with New Cpanel Backups.
After completing the migration I configured the Backup (New Not Legacy).
The new backup has the benefit that it gives you the option to keep the backup in the local server and the remote server too.
I have enabled the backup, I made sure "Backup Accounts" is selected, and I made sure that under "Select Users" all users were enabled for backup.
I had also configured a remote server with FTP here. First I tried SFTP but it was giving an error, and when I researched it was a known issue with SFTP, so I configured FTP and it validated it.

I had set to backup daily (All Days) and retain 3 daily backups.
I had also set to backup Monthly (1st and 15th) and retain 2 monthly backups.

The first daily backup happened both local and remote without any problems, and I got the log in email.
Now after the first backup subsequent daily backups are just not happening.
They normally happen around midnight, and by morning I get the log in mail. There have been no mails and when I check the /newbackup folder which I have configured for backups, it has just the one first backup.

There is only one file (which i suppose is of the first backup as it has the date of 21st May when my first backup completed) in /usr/local/cpanel/logs/cpbackup . This log file is attached here.
There are no subsequent files in that folder.

I did add a few lines in the root cron job file to add some cron jobs from my old server. I did not delete anything from there though. Is the backup also configured as a root cron ?

What I have tried so far.
In WHM-Backups-Select Users - I disabled all users for Legacy backup
That did not help.

Then I desperately needed one backup so I ran /scripts/cpbackup
This gave a message that "Legacy Backup is not configured" so I guess cpbackup runs the legacy backup.
I did enable all users for legacy backup again and ran /scripts/cpbackup again, and it did do a complete backup in the /backup folder.

What is the command to run the New Backup manually ?
Any ideas why the Backups are not running, and what I could do to resolve this.

Thanks & Regards


Active Member
Mar 9, 2006
Ok I have figured it out.
I had edited the root cron file /var/spool/cron/root in wordpad in windows.
This screwed up the file, and since the cron for backups is also in this file it did not run for a few days.
Now I reverted back to the original file and backups ran perfectly last night.
Sorry for that


Staff member
Apr 11, 2011
Hello :)

I am happy to see that you resolved the issue. Thank you for updating us with the outcome.

Thank you.